Please read and follow the COMMON ISSUES first!
Always add your version information in every new post! Thank you!

Form2Content Forum

Questions and answers for Form2Content, a Joomla CCK.
  1. Thom
  2. F2C field types
  3. Monday, 07 December 2015
  4.  Subscribe via email
Hi there,
I'm using Joomla! 3.4.5. and F2C Pro 6.12.0
My site has a secure certificate. I'm getting an error message that I am loading non-secure images. When I check F2C, I see that the images have an "http://" URL rather than an "https://" URL. Here is my template:
{php}setlocale(LC_ALL, 'nl_NL');{/php}
<h2>{$JOOMLA_TITLE}</h2>
<div class="blogdatum"><small>Gepubliceerd:{$JOOMLA_PUBLISH_UP_RAW|date_format:"%e %B %Y"}</small></div>
<div class="lead">{$INLEIDING}</div>
<div class="img-blog">{$AFBEELDING}</div>
<div class="blogbody col-md-8 col-md-offset-2">{$ARTIKELBODY}

<div class="blogauteur">{$AUTEURSNAAM}</div>
<div class="blogauteurbio">{$AUTEURFOTO}{$AUTEURBIO}</div>
</div><!-- einde blogbody -->
<div class="bloglijn"><hr /></div>

Perhaps I should add that I am using 'html image tag' rather than 'raw image url' as I suspect this has to do with it.

How do I get F2C to load the images using "https:// "?

Thanx,


Thom
thomsterdam.nl
References
  1. https://www.chjc.nl/chjc/blog
Accepted Answer
Accepted Answer Pending Moderation
Hi there,

Thanks Julian, for putting me on the write track. After a bit of reading in the F2C Documentation and the cheat sheet I've got the answer:
This is what I've done:
I have added {$AFBEELDING_PATH_RELATIVE} then I put the necessary HTML around it, so now it reads:
<div class="img-blog"><img src="{$AFBEELDING_PATH_RELATIVE}" /></div>
The rest you can see in the attached image.

Thanx again,

Cheers,


Thom
Attachments (1)
  1. more than a month ago
  2. F2C field types
  3. # Permalink
Responses (6)
Accepted Answer Pending Moderation
Hi Thom,

The best way to deal with https (or a mix of http and https) is to use relative image paths.
A relative path does not contain the protocol and can be used in both situations.

You can use a parameter like this: {$<fieldname>_PATH_RELATIVE}
This path is relative to images/stories, it could be that you need some extra hard coded prefixing in your template.

best,
Julien
  1. more than a month ago
  2. F2C field types
  3. # 1
Accepted Answer Pending Moderation
Hi Thom,

The best way to deal with https (or a mix of http and https) is to use relative image paths.
A relative path does not contain the protocol and can be used in both situations.

You can use a parameter like this: {$<fieldname>_PATH_RELATIVE}
This path is relative to images/stories, it could be that you need some extra hard coded prefixing in your template.

best,
Julien
  1. more than a month ago
  2. F2C field types
  3. # 2
Accepted Answer Pending Moderation
hi Julien,

As you can gather from my question, I don't know how to configure that. I am using the automatic template as generated by F2C. In it there is the {$AFBEELDING} which is the first image (afbeelding is Dutch for image) and then at the bottom there is {$AUTEURFOTO} which is the author's photograph. The forum software stripped away the HTML code so I'm trying to paste the code here again:

Because the forum software keeps on removing the html in my post, I have attached it in an attached screenshot image.
I don't know how to use your suggestion, although I know that is the way forward. How do I incorporate {$_PATH_RELATIVE} etc. instead of the {$AFBEELDING} which I am using at the moment? I have only just started using F2C and do not know how to make the templates (yet).

Cheers,


Thom
Attachments (1)
  1. more than a month ago
  2. F2C field types
  3. # 3
Accepted Answer Pending Moderation
Hi Thom,

Good to read that you found out how it works! :)

best,
Julien
  1. more than a month ago
  2. F2C field types
  3. # 4
Accepted Answer Pending Moderation
Although this question is almost four years old and marked as resolved there was no satisfying answer given for me.

For all of you still using F2C content manager who stumble about mixed content warnings.

The solution is:
After switching Joomla (3) to enforce https (on Global Configuration -> Server) you have to open every F2C article that contains images and save and exit it again.

By that the image link is rewritten to use https and the page no longer produces the mixed content warning.
  1. more than a month ago
  2. F2C field types
  3. # 5
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.