Please note that Form2Content is no longer being developed. All files from the latest version can be found on Github.

Form2Content Forum

Questions and answers for Form2Content, a Joomla CCK.
  1. Mandy van Dissel
  2. F2C field types
  3. Monday, 21 September 2015
  4.  Subscribe via email
F2C Pro 6.11.0
Joomla 3.4.4

I have used F2C to set up several article creation options, with different content types, saved in different categories, and added several articles via the front-end forms. Then updated to Joomla 3.4.4.

After that I changed the text of an already created article (via F2C front-end created and edited) and suddenly the text appears in different sizes after saving.
The Joomla update probably has nothing to do with it, because if I add a new article the problem does not occur at first publishing and I had not adjusted the previously published articles before updating. So the problem starts with the adjusting of the articles and only in a certain content type (with editor field).

Previously I would find something like this in the joomla article (JAM) that was created by F2C:

<p>Text paragraph.</p>
<p>Text paragraph.</p>
<p>Text paragraph.</p>

But after adjusting the article I find something like this:

<p>Text paragraph.</p>
<p><span style="font-size: 12.16px; line-height: 1.3em;">Text paragraph.</span></p>
<p>Text paragraph.</p>

I tested this several times, both via filling the form in the back- and front-end, by clearing the content of the article and adding new text. It seems pretty random what happens; sometimes the result is as it should be, but most of the time the problem occurs. Tested different articles, several times. Problem is not related to length of text, using copy/paste or image added or not. However it does only occur in a content type with an Editor field.

By the way: no font size or line-height was/is available in the Editor in the F2C form on the front-end.

So I think the problem might be related to the ‘Multi-line text (editor)’ field or to the JCE editor, because I also tested some of the other content type forms again, were only ‘Single line text (textbox)’ and ‘Multi-line text (text area)’ are used, and the problem does not seem to occur in these forms.

Just for investigation purposes I also adjusted the Joomla article (JAM) directly by clearing it’s content and replacing it, only using JCE in wysiwyg mode. This gave a good result (no more font-size: 12.16px; line-height: 1.3em). Of course this is no solution, but it might give you an idea about where this problem may be located.
Also tried making a new content type with the same specifics (including the editor field again) and the same problem occurred again.

This is the F2C template for the article:

{$EDITOR}
{if $IMAGE}<img src="{$IMAGE}" alt="{$JOOMLA_TITLE}" style="margin-left: 20px; margin-bottom: 10px; border: 1px solid #3a0100; float: right;" />{/if}

Were {$EDITOR} stands for the Multi-line text (editor) field.

Articles were previously created using JCE 2.5.2, so when the problem first occurred (after upgrade to J 3.4.4.) I immediately updated JCE to the latest version (2.5.8) too, but that did not solve the problem.

Any idea what I’m doing wrong here?
Thanks in advance for your reply!
Responses (6)
Accepted Answer Pending Moderation
Sorry forgot that I'm using code, see attachment.
Attachments (1)
  1. more than a month ago
  2. F2C field types
  3. # 1
Accepted Answer Pending Moderation
Hi Mandy,

Strange indeed. The chance that it's a F2C issue is very small. As you can imagine we "just" load the editor.
After that the editor is in control of the content. Usually editors add stuff like < p > tags. This kind of styling I usually only see if people copy paste from other source like websites or Word.

If it's random and we can't re-produce it's very tricky to find out the cause. So far we have not had others report this behavior. If you change your editor to tinymce does the same behavior occur? If not it really seems like a JCE issue.

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. F2C field types
  3. # 2
Accepted Answer Pending Moderation
Thanks for your reply Patrick. I'm glad I'm not the only one finding this strange.

I tested with pasted text (via notepad, so nothing from another website or word) and also tested with directly typed text, but the problem seems to occur both ways. So that has nothing to do with it.
And yes the problem occurs random, but with that I mean that every time I change the content the smaller font size shows up on a random place in the text. And out of say 10 tests, only 1 time the problem does not occur. So I can easily reproduce it over here ;)

I tested if the problem still occurs with tinymce and you're right; nothing strange happens when tinymce is the default editor.
What I find strange though is that the problem doesn't occur either when I use JCE to adjust the article directly in the JAM.
And because I have never experienced this problem before (and have been using JCE for many years), that made me think that the problem could be initiated by the combination of JCE and F2C. Is that possible at all?

The reason I prefer JCE over tinymce is because with JCE I can fully control the appearance of the editor, so that it shows only the few buttons I want the user to have access to. In tinymce you sort of have the choice between too little buttons (like 'simple' does not have a link button or choice for a specific header) or way too many options via 'advanced' or 'extended', no matter what. Or maybe I'm not using tinymce the right way and it's more flexible than I think?

However, I'm still hoping to find a solution to this, any ideas?
  1. more than a month ago
  2. F2C field types
  3. # 3
Accepted Answer Pending Moderation
Because I'm running out of time, I decided to replace the editor field in the content type by a text area field and a hyperlink field. Because I didn't want to start from scratch, I added these fields to the existing content type first so I could copy and past the content of the editor field to the text area (done via frontend and with JCE set as default editor) before removing the editor field.

Two things happened:
1. after adding the other fields the problem suddenly no longer occurs in the editor field. I made several changes on several pages to the content in the editor field to test this; worked fine then.
2. because I wanted to add some info for the hyperlink field I added an info field too. Entering the content in the info field submission form is done through the editor as well. After opening the form in the frontend to view the result, the problem did occur here again (and could be solved by adjusting the code in the editor in the info field submission form).

I now wonder if the problem only occurs when an (JCE) editor field is the only text field used.

So this is a workaround, but for lack of a better solution it will have to do for now ;)
  1. more than a month ago
  2. F2C field types
  3. # 4
Accepted Answer Pending Moderation
Hi Mandy,

Since I haven't yet been able to reproduce and we have no other reports I can't do much else than keep an eye out for the issue. Like you, many use JCE. With F2C we just load the position for the Joomla editor, nothing else. The only other thing I can think of is maybe extra css which is loaded by JCE than might influence your content but it would still be strange.
Like I said, we'll keep an eye out.

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. F2C field types
  3. # 5
Accepted Answer Pending Moderation
Thank you Patrick.

I will let you know if I find out what is causing this to happen.
  1. more than a month ago
  2. F2C field types
  3. # 6
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.