Please read and follow the COMMON ISSUES first!
Always add your version information in every new post! Thank you!

Form2Content Forum

Questions and answers for Form2Content, a Joomla CCK.
  1. Brendan Hedges
  2. Form2Content Lite & Pro
  3. Sunday, 07 July 2019
  4.  Subscribe via email
Hi
F2C 5.6.0
Joomla 3.9.8

I would like to know if the multi select field is suitable for the following.

I have a list if icons to display in an article dependant on the amount selected. These are called via css. There are 15 in total to choose from, on average maybe 6 -7 will be selected to display in the article.

The code that would need to be rendered follows this format ---- <li class="tesda" rel="tooltip" data-original-title="Accredited by TESDA"></li> -----. I would like the select option in the article form to be 'Tesda', then all I would need in the template would be {$TESDA}

Are the field lengths long enough, I tried the single select field, but the field lengths are too short.

Any thoughts?

Regards, Brendan
Accepted Answer
Accepted Answer Pending Moderation
Fixed it!

Isn't it annoying that no matter how long you scrutinize something that should be simple, you can't see the obvious!

in your original code you sent this:

<ul>
{foreach from=$BADGE_OPTIONS key=k item=i}
<li>class="{$k}" rel="tooltip" data-original-title="Accredited by {$i}"></li>
{/foreach}
</ul>

it should have been this:

<ul>
{foreach from=$BADGE_OPTIONS key=k item=i}
<li class="{$k}" rel="tooltip" data-original-title="Accredited by {$i}"></li>
{/foreach}
</ul>


Can you spot the difference?

:)


Thanks once again.

Regards, Brendan
Responses (27)
Accepted Answer Pending Moderation
Hi Brendan,

The field renders an array (a set of selected options).There are two ways to do what you want.

1) You need to check if a value is present and if so display the corresponding html (icon or list item in your case). If I understand correct you have a max. of 15 checks. You would need to use if in array function.

2) You generate the list and display the different icons based on css (easier)

The code could look like this if your field is called OPTIONS

<ul>
{foreach from=$OPTIONS key=k item=i}
<li>class="{$k}" rel="tooltip" data-original-title="Accredited by {$i}"></li>
{/foreach}
</ul>

Note that you can add two values in your field per option, one the key(value) and one the text (item) value. You can use the key for the css and the text for the display.

Hope this helps!

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Thanks for that Patrick.

I purchased the pro version tonight, but no account activation email was sent, so I can't access the download area.

I've sent you an email about this.

Regards, Brendan
Accepted Answer Pending Moderation
Hi Brendan,

Apologies, our webshop didn't receive the confirmation from PayPal. I have activated your subscription.

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Thanks Patrick
Accepted Answer Pending Moderation
Hi Patrick,
I installed the pro version directly over the lite one, as advised on the website.

I can see the extra field choices in the image fields etc, but I when I try to select a field type from the drop down box, the additional fields that are available in the pro version are not listed.

Am I missing something?

Regards, Brendan
Accepted Answer Pending Moderation
Hi Brendan,

No this should work. Can you try re-install the F2C Pro? (without uninstalling!)

If you don't have any F2C forms/content that you need you can uninstall F2C and install Pro again. We will want to try figure out the upgrade issue as it's not common this doesn't work.

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
HI Patrick, I just tried to reinstall again, but it is still the same.

Incase it makes a difference I am on localhost using wamp.
Apache 2.4.27 - PHP 7.1.9
MySQL 5.7.19
MariaDB 10.2.8
PHP 5.6.31 for CLI (Command-Line Interface)

Joomla 3.9.8

One thing I noticed is the file name of the zip. It says com_form2content_pro_6.17.4_j3.7.x.zip

The description from the download page says 'PLEASE NOTE:This release has many changes if upgrading from F2C 6.16. PLEASE BACKUP before upgrading!! It is for for Joomla 3.8 and above!

There is a discrepancy in the Joomla version.'

I do have a current form/fields/article I am working on. I assume I can just export them and then import them again into a fresh install?

Regards, Brendan
Accepted Answer Pending Moderation
Hi Brendan,

The Joomla version name isn't a problem. The import/export is as it requires the same version. Can you make one now (in your upgraded F2C) )and send it to me. I will check if I can import it. If so you can uninstall and do clean install.

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
ok will do it now
Accepted Answer Pending Moderation
here are the exports.

Out of interest the forum upload function would not let me upload the .tpl files, yet it says they are of an allowable file type for upload, hence the zip file.
Attachments (1)
Accepted Answer Pending Moderation
The .tpl are part of the xml ;)

I successfully installed the XML file and it added the content type and templates.
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Hi,
It wont let me delete the install, it returns an error:
Joomla\Filesystem\File::delete: Failed deleting inaccessible file fields
Joomla\Filesystem\File::delete: Failed deleting inaccessible file css

Maybe this is the reason those fields are missing?

I checked the tmp folder incase there is something in there causing this, and there is a reference to f2c_import. But as yet it will not let me delete that manually, even trying filezilla. It says I need admin rights, but even when those are granted, it still will not let me delete it manually.
Accepted Answer Pending Moderation
Mmmmhh this is very strange and not happened before.

If you re-install F2C even though the uninstall wasn't complete does it work? If there are admin rights on FTP that is very "old fashioned". That hardly ever happens any more. It means your website installs with different rights, might even be the cause of the issue in the first place...
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Hi.
I tried to reinstall and it now returns this error.
An error has occurred.
-1 Cannot create destination folder

I checked the DB fix - no errors
I checked , rediscover - nothing
Accepted Answer Pending Moderation
This really seems to be a permissions issue with your file server. You should be able te remove the files via FTP. Do you have "install via FTP" on in your website settings? (should not be used)
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
I downloaded again from your website, and tried installing, i get an error from the joomla installed now.
Internal Server Error, in red. Rather than an error as before.

I'll try a restart for wamp and see what happens next.
Accepted Answer Pending Moderation
I know there are extensions that provide file access via Joomla backend. Like a file explorer. Perhaps you can install that and then have the correct permissions to remove the directories.

In the long run I would think about a host that doesn't use this type of permissions setup.
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
The install is on localhost via wamp.

A pc restart allowed me to delete the files in the tmp folder via filezilla :)

However, while I tried to reinstall f2c I now get a new error!
Warning
Table 'esl.#__f2c_form' doesn't exist
×
Error
Error installing component
Accepted Answer Pending Moderation
I tried to install f2c lite again. this also retuns an error

Warning
Table 'esl.#__f2c_fieldtype' doesn't exist
×
Error
Error installing component
Accepted Answer Pending Moderation
very strange...

after getting the install error for f2c lite, there was no link for it in the components menu, as to be expected.
But when I checked the manage files section, there it was listed. so I uninstalled it, and it seemed to be deleted without trouble.

I shall now try to install pro again and report back.
  • Page :
  • 1
  • 2


There are no replies made for this post yet.
However, you are not allowed to reply to this post.