Please note that Form2Content is no longer being developed. All files from the latest version can be found on Github.

Form2Content Forum

Questions and answers for Form2Content, a Joomla CCK.
  1. RegistryAlliance
  2. F2C Front-end / menu settings
  3. Tuesday, 26 April 2016
  4.  Subscribe via email
Having trouble with the edit button not showing up on the front-end.
Joomla 3.4.8, F2C Pro 6.12.0
Button plugin published and active, set to run "first" in the order
Tried it with both the default link (empty box in plugin) and adding the following code:
<p>{ldelim}f2ceditarticlebutton{rdelim}{ldelim}/f2ceditarticlebutton{rdelim}</p>

Before adding the plugin, Joomla rendered the above with all of the {}s. Once plugin installed and running, that disappeared, but still no button. Checked article and content type permissions, am superuser, all permissions set to allowed for superuser.

Button still does not show, but the "<p></p>" does, which leads me to believe F2C is pulling out the code and not displaying the button. Help?
Accepted Answer
Accepted Answer Pending Moderation
Just to be clear. This code goes in your F2C template:
{ldelim}plgContentF2cEditArticleButton{rdelim}{ldelim}/plgContentF2cEditArticleButton{rdelim}

And if you want a custom link you can add something like this within the HTML field of the plugin.
< a href="{$LINK}" class="uk-button" >My edit link text< /a>

As per documentation:
http://documentation.form2content.com/f2c-extensions/joomla-plugins/134-f2c-front-end-edit-article-button
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Responses (2)
Accepted Answer Pending Moderation
I've also loaded jQuery Easy per instructions and that brought back the "{f2ceditarticlebutton}{/f2ceditarticlebutton}" but no button
  1. more than a month ago
  2. F2C Front-end / menu settings
  3. # 1
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.