Please read and follow the COMMON ISSUES first!
Always add your version information in every new post! Thank you!

Form2Content Forum

Questions and answers for Form2Content, a Joomla CCK.
  1. Ulrich Griesshaber
  2. Form2Content Lite & Pro
  3. Thursday, 22 November 2018
  4.  Subscribe via email
I am using Form2Content Pro Version 6.17.2.
Captcha doesn't work and I got spam attacks.
No capchta is displayed in form. See attached URL ..../service/test-f2c/article/new/
Public and private key of captcha is configured in F2C
In other forms (BreezingForm) captcha is working. See second attached link .../termine/dpevent-erstellen
Do I need to configure anything else?
References
  1. https://www.blasmusikverband.de/index.php/service/test-f2c/article/new/
  2. https://www.blasmusikverband.de/index.php/termine/dpevent-erstellen
Accepted Answer
Accepted Answer Pending Moderation
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Responses (14)
Accepted Answer Pending Moderation
Hi Ulrich,

Three things, please update to latest version as we have solved some bugs. Can you try re-captcha version 2, so not the hidden (version 3) and last it seems you also need to add your Google Maps ID and related library permissions.

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
I updated version.
I do not go back to V2 version of captcha
Ich changed back to V2 for new URL.bv-schwarzwaldbaar.de
https://www.bv-schwarzwaldbaar.de/index.php/service/test-merktplatz/article/new/
I configured the new V2 keys.
But no effect.

I do not use google maps. That is just for testing.
References
  1. https://www.bv-schwarzwaldbaar.de/index.php/service/test-merktplatz/article/new/
Accepted Answer Pending Moderation
Hi Ulrich,

Thanks for the update. Are you using a (submission) form override? If not can you send me back-end access so I can have a look?

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
PS you can send it to support at opensourcedesign dot nl
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
OK I see the problem. You need to add the actual Captcha field to the form. The global key settings which you added have no effect as they are for maintaining backwards compatibility. Sorry for the confusion, I will see if we can make this clearer.

PS I added the field to your last example.

Regards, PAtrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Nice to know if this solved your problem....
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Thank you!:)
Separate captcha field!
I looked for such a filed, but didn't find it.
I looked in the "All field example".
But there is no captcha field.
For me it would have been be sufficient to add the captcha field the example.
Issue may be closed.
Accepted Answer Pending Moderation
The problem is if we do that the form doesn't work immediately ;)

Regards and enjoy Form2Content!
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
I am having the same issue. How can I add the captcha field? I don't see it when I try to create a new field. Please advise.

I am using the latest Pro version.
Accepted Answer Pending Moderation
Hi Arbind,

Go to the fields manager for your content type, click on new field, select the first field in the drop-down called Captcha.... it's actually already pre-selected ;).

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Hi Patrick,

As I said in the original post, there is no "Captcha" field when I try to create a new field.

I investigated this, and I can see there is some issues and you need to improve the installer. I will explain it here with the hope this would help you to improve the installer.

When you first install the lite version, and then, install the pro version, here are the things that the pro-version-installer is NOT doing, which is the main cause of the issue:

(1) The pro-installer is not inserting the "captcha" row in the __f2c_fieldtype table.
Add the script to the pro-installer to do so.

(2) In the same table, in the classification_id column, the pro-installation is not changing the values from 0 to 1 for those non-joomla-values.
Add the script to the pro-installer to do so.

Again, this happens when you first install the lite version and then the pro version. So, it looks like, may be, you need to add these scripts to the update (not new install) script.

I have already fixed the issues by manually altering my database. But you should fix this so that it would help the non-technical users.
Accepted Answer Pending Moderation
Hi Arbind,

Thanks for the clear explanation, this helps us a lot!!
I will pass it on to our programmer immediately.

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Hi Arbind,

Thank you for your detailed explanation. Yes there was a bug in the script and I have fixed it now, to be included in the next version.

best,
Julien
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.