Form2Content Forum

Questions and answers for Form2Content, a Joomla CCK.
  1. Steve
  2. F2C installation questions
  3. Friday, 29 June 2018
  4.  Subscribe via email
I screwed up and created Template file names with Dashes in them rather than Underscores.

I upgraded to 6.17.2 from the earlier stable version directly below that release.

I went to modify one of the Templates whose filename had a Dash in it and got an error (because version 6.17.2 doesn't like the dash).

I downloaded the template files, renamed them with Underscores removing the Dashes, uploaded them and finally adjusted my Content Type to apply them.

NOW, I can’t delete the existing articles for some reason. When I try it just ignores the command and keeps the “check mark” in front of the F2C article. I’ve tried via Front and Back end using the Super Admin login. I can wipe them out in Joomla directly but they are still listed in F2C and will cause confusion for my client.

What is the best way to resolve this situation so I can delete articles? I’m finding that I used the dreaded Dash in other websites with quite a few existing articles and I’d like to upgrade F2C without problems.

Detailed Specs:
Joomla 3.8.10
Form2Content Pro 6.17.2
Linux hosting
PHP 7.1.14
Server is gray in color

Thanks, in advance.
Responses (4)
Accepted Answer Pending Moderation
Hi Steve,

Thanks for the detailed explanation. I think Julien will need to look at this but I do have a question.

When you say you want to delete teh articles, do you mean:
1) Delete the Joomla articles including the F2C data i.e. delete via Form2Content
2) Delete the Joomla articles (via JAM) but keep F2C data so you can re-create the Joomla articles

I believe the first but just want to check ;)

Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. F2C installation questions
  3. # 1
Accepted Answer Pending Moderation
Yes, I'm in the Article Manager of F2C attempting to delete articles. I tried both the front end and back end using the Super Admin login.

This is the second site I had this happen so I got serious with troubleshooting because I have quite a few sites where I used a Dash in the Template filenames and they have quite a few articles.

After the upgrade to 6.17.2 things work fine with Template files having a Dash in them as long as you don't need to modify those Template files. Attempting to modify the Template files in 6.17.2 will display an error if there is a Dash in the filename and will not allow you to modify the Template file. Naturally the work around is to change the Template filename and apply that newly named file to the Content Type BUT it causes this "cannot delete articles" scenario.

Just FYI I did not do a full new installation of 6.17.2 in Joomla for these websites, I've just upgraded from previous versions using a generic Joomla environment that I start a design process with.

I'm not sure why a Dash in the Template file naming conventions is disallowed but if you could allow this in 6.17.2+ versions it would resolve this problem.

This sure resembles some type of a Permissions issue.

I sent access for the site to your This email address is being protected from spambots. You need JavaScript enabled to view it. email. Feel free to login and take a look.
  1. more than a month ago
  2. F2C installation questions
  3. # 2
Accepted Answer Pending Moderation
Hi Steve,

I looked at your site, and this is what I think happened:

You had existing articles, renamed the template and set this template at Content Type level.

From that point newly created articles use the new template as specified in the Content Type.
However, existing articles will still use the old template name.

There are two ways to resolve this:

1) Open the articles in the back-end, select the new template and save them.
2) Update the correct template names directly in the database (table #_f2c_form, columns intro_template and main_template)

Hope that helps!

  1. more than a month ago
  2. F2C installation questions
  3. # 3
Accepted Answer Pending Moderation
Thanks Julien! Adjusting each old article to use the correct template worked. I never noticed I could do that. I'll probably just modify the database.
  1. more than a month ago
  2. F2C installation questions
  3. # 4
  • Page :
  • 1

There are no replies made for this post yet.
However, you are not allowed to reply to this post.