Please read and follow the COMMON ISSUES first!
Always add your version information in every new post! Thank you!

Form2Content Forum

Questions and answers for Form2Content, a Joomla CCK.
  1. Marco
  2. Form2Content Lite & Pro
  3. Monday, 25 March 2019
  4.  Subscribe via email
Hi,

after migration I can't create new Form2Content post.
I go to create articole, select one of my template.
After I fill the field and press save I get:

"Salvataggio fallito con il seguente errore: F2C Identificativo articolo : COM_CONTENT_WARNING_PROVIDE_VALID_NAME"

(Means
Save failed with the following error: F2C article ID: COM_CONTENT_WARNING_PROVIDE_VALID_NAME)

If I try to edit existing content, some save and other doesn't save.

Thank you for help.

Marco.
Accepted Answer
Accepted Answer Pending Moderation
Hello Marco,

I have already sent you the solution, but I will write it on the forum, so other user can benefit from it too.

The Content Type that did not save had a lot of fields on it.

On the new server the PHP setting max_input_vars was set to 1000 (default value).
This is the maximum number of fields you are allowed to upload in a single post.
See: https://www.php.net/manual/en/info.configuration.php

However, this Content Type exceeded this number. In fact, on the old server the value was set to 3000.

After setting the value to 3000 on the new server, everything worked again.

best,
Julien
Responses (15)
Accepted Answer Pending Moderation
Hi Marco,

Can you add your version numbers of F2C and Joomla? How did you perform the migration? Is there a difference in server php etc.? Have you cleaned your cache/tmp files?

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 1
Accepted Answer Pending Moderation
Hi!

So, I redid the migration because I noticed there were some issue with tables primary key.
Now this is the situation:

I had to migrate the website from a php 7.2 to a php 5.6.40 server due to Joomla template not compatible with php 7.2.

I updated Joomla to latest version (3.9.4) and upgraded F2C PRO to latest version (6.17.4)

I can't save articles with associated a specific Content Type.

When I click "save", it returns back to list not saving and without errors.

I can create or edit articles with any other Content Type.
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 2
Accepted Answer Pending Moderation
OK, from what version did you come for both Joomla and F2C? If you have a low F2C version try upgrading to 6.16 first as 6.17 has many changes. Will be back in 2 hours.
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 3
Accepted Answer Pending Moderation
Yes, I did in this way.
I upgraded from 6.7.0 to 6.16 and then to 6.17, without issues.

If I give you access to website, could you have a look?

Thanks.
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 4
Accepted Answer Pending Moderation
Hi Marco,

Have you used Akeeba backup to migrate the website? We have no known issues nor have I ever had any with migrating. Only if something in te database changes (which shouldn't happen) does it go wrong. That is a part which we can't help with.

Have you checked the database using the Joomla tools? If you migrate and not yet update F2C does it work? Also to narrow down the issue. Can you create a new F2C content type and add an article to see if that works?

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 5
Accepted Answer Pending Moderation
Everything else works fine.
I created a new Content Type and works.

It's something related at that given content.
The strange thing is there is no error message when i click save.
I don't know if there is a debug.

The content type is quite big (10 pages of fields and I don't want to redo it).
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 6
Accepted Answer Pending Moderation
OK so let me summarize, after migrating to a lower php server you update F2C from 6.7 to 6.16 and 6.17.4. New content types work fine but when you try to add or edit existing content you get.
(COM_CONTENT_WARNING_PROVIDE_VALID_NAME)?

Can you also answer my other questions about HOW you migrate. It does point to something changing in the DB after migration since new content type works fine. Please be as specific as possible with the details.

And of course we don't want you to redo anything :)
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 7
Accepted Answer Pending Moderation
PS Two more questions:

1) Does it work in back-end
2) Have you checked permissions (with Joomla update these have changed)
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 8
Accepted Answer Pending Moderation
I simply exported and imported DB on new server, copied files and changed Joomla configuration.

I think it's something related to specific Content Type because when editing other articles of other content types it works but when editing articles with that specific content type it doesn't save (no error or message shown, it simply closes the article and go back).

I don't think it' something related to Joomla permission because if so, every content in F2C should have the same problem.
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 9
Accepted Answer Pending Moderation
OK, thanks for the update, important information! Permissions are set per content type .... so it can be that but not in the back-end when logged in as admin.

Can you send me admin account to info at opensourcedesign dot nl? I will see if I can narrow it down.
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 10
Accepted Answer Pending Moderation
Sent the email!
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 11
Accepted Answer Pending Moderation
Why do you have: Numero massimo di F2C Articoli per utente set to 0? (Maximum number of F2C Articles per user)
But this didn't solve the problem.....

I don't know if your website is live but can you switch on error reporting and see what comes up. It's very strange that if I click cancel after editing an article, the filter settings are lost in F2C. So even with cancel something goes wrong. But it might be the acymailing integration too .....
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 12
Accepted Answer Pending Moderation
I didn't changed "Maximum number of F2C Articles per user". However the tooltip says: zero or empty no limits.
I tried disabling Acymailing, no changes.
Enabled Joomla "Debug" but no messages.
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 13
Accepted Answer Pending Moderation
OK, I will have to ask Julien to take a look as this goed beyond what I can do. Haven't seen this behavior before. I just hope it's not initiated by another extension.
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
  1. more than a month ago
  2. Form2Content Lite & Pro
  3. # 14
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.