Please read and follow the COMMON ISSUES first!
Always add your version information in every new post! Thank you!

Form2Content Forum

Questions and answers for Form2Content, a Joomla CCK.
  1. Trevor Smith
  2. F2C submission form templating
  3. Saturday, 03 November 2018
  4.  Subscribe via email
Hi

I have just moved a site to a new server and now I get a 4o3 error when I submit a form with an http:// or https: url prefix. The field in question is a Hyperlink type.

It works OK from the back-end admin area.

I have tried various field settings - Raw and href tag and I have also tried enabling/disabling Add http prefix.
I have also checked the permissions which look OK.

Any suggestions?

regards
Trevor
Responses (5)
Accepted Answer Pending Moderation
I went back to the site on the old server and updated Joomla to 3.9.0 and it worked OK so it's not related to the Joomla update.
Accepted Answer Pending Moderation
More test results. . .
I created a sub-domain on the new server and loaded Joomla 3.9 and f2c and get the same results using the 'All fields' example.

It feels like it is related to the server configuration. Here are the php libraries that are installed and the highlighted ones are those that are installed on the old server but not on the new one.
php-libraries.png
Are any of these needed by f2c?
Attachments (1)
Accepted Answer Pending Moderation
After further testing I found that the problem also occurs if I enter a hyperlink into a text field (single line or multi line).

As mentioned earlier this only happens in the front-end even when logged in as super-user. Entries from the back-end work OK.

I have also set up a new Joomla site on a different server (from the same hosting company) and get the same results.
Accepted Answer Pending Moderation
Hi Trevor,

Thanks you for the added information. I will have to ask Julien to see if he can spot the issues or difference in php. At the moment the issue isn't known but maybe J3.9 is doing something strange again.

Can you provide your version info please?

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Hi Patrick

I am using:
Form2Content Pro version 6.17.4
Joomla 3.90
PHP 7.1.23
MariaDB 10.2.18
Lightspeed webserver

regards
Trevor
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.