Please read and follow the COMMON ISSUES first!
Always add your version information in every new post! Thank you!

Form2Content Forum

Questions and answers for Form2Content, a Joomla CCK.
  1. Trevor Smith
  2. F2C submission form templating
  3. Saturday, 03 November 2018
  4.  Subscribe via email
Hi

I have just moved a site to a new server and now I get a 4o3 error when I submit a form with an http:// or https: url prefix. The field in question is a Hyperlink type.

It works OK from the back-end admin area.

I have tried various field settings - Raw and href tag and I have also tried enabling/disabling Add http prefix.
I have also checked the permissions which look OK.

Any suggestions?

regards
Trevor
Responses (13)
Accepted Answer Pending Moderation
I went back to the site on the old server and updated Joomla to 3.9.0 and it worked OK so it's not related to the Joomla update.
Accepted Answer Pending Moderation
More test results. . .
I created a sub-domain on the new server and loaded Joomla 3.9 and f2c and get the same results using the 'All fields' example.

It feels like it is related to the server configuration. Here are the php libraries that are installed and the highlighted ones are those that are installed on the old server but not on the new one.
php-libraries.png
Are any of these needed by f2c?
Attachments (1)
Accepted Answer Pending Moderation
After further testing I found that the problem also occurs if I enter a hyperlink into a text field (single line or multi line).

As mentioned earlier this only happens in the front-end even when logged in as super-user. Entries from the back-end work OK.

I have also set up a new Joomla site on a different server (from the same hosting company) and get the same results.
Accepted Answer Pending Moderation
Hi Trevor,

Thanks you for the added information. I will have to ask Julien to see if he can spot the issues or difference in php. At the moment the issue isn't known but maybe J3.9 is doing something strange again.

Can you provide your version info please?

Regards,
Patrick
Please read the F2C documentation before asking questions! Thank you if you've done so ;)
Accepted Answer Pending Moderation
Hi Patrick

I am using:
Form2Content Pro version 6.17.4
Joomla 3.90
PHP 7.1.23
MariaDB 10.2.18
Lightspeed webserver

regards
Trevor
Accepted Answer Pending Moderation
Hi Patrick

Any progress on this issue please?

Best regards
Trevor
Accepted Answer Pending Moderation
Hi Trevor,

I think I have seen this issue before, but I'm not sure if we found a fix for it.
I think this is a security setting related issue that is hard to pin-point. Since the issue occurred after a server move, it must be a (security) configuration issue.

Have you checked PHP logs / security logs and access logs for your server?
Any hints in there?

best,
Julien
Accepted Answer Pending Moderation
Hi Julien

I noticed that there was an update to PHP a few days ago so I updated to 7.1.24 and the problem has gone away:D

The new server was previously running 7.1.23 but the old server was using a previous version so I guess 7.1.23 introduced a bug which caused the issue.

I will run some more tests but It looking good.

Thanks again for your help.

Best regards
Trevor
Accepted Answer Pending Moderation
I might have been a bit hasty, the problem has returned - well it never went away, I was testing the wrong site !

There is nothing in the logs that I can access and I also tried going back to php5.4 without success.
Accepted Answer Pending Moderation
Hi Trevor,

Have you contacted your host about this error? Maybe they know of some specific setting that is causing this behaviour?

best,
Julien
Accepted Answer Pending Moderation
Hi Julien

The problem has been resolved - it was hitting a modsecurity rule which has now been removed.

Thanks again for your help.

Best regards
Trevor
Accepted Answer Pending Moderation
Thank you for reporting this, I think this issue would be impossible for me to find!

Do you have information about the modsecurity rule? I'm interested to have this, when it happens for other user.

best,
Julien
Accepted Answer Pending Moderation
Hi Julian

I contacted my hosting company who found what was causing the issue:

The rules that were disabled are:
340161
340162
340163

I have copied the log of the block in the private area.

I have since found several reports by googling for modsecurity 340163

You might find this one might useful:
https://wiki.atomicorp.com/wiki/index.php/WAF_340163

Hope that helps.

Best regards
Trevor
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.